Get in touch
Back
Degraded

LifeBac Services Degraded

Started 28 Sep at 11:37am PDT, resolved 28 Sep at 02:00pm PDT.

Sign Up Form Client Web Portal
Resolved

AWS has resolved the issue and all services should recover soon.

Posted 28 Sep at 02:00pm PDT.
Created

Due to an issue with AWS in the US-West-2 region where most of our services are located, the mobile app and web portal as well as our call centre are currently down or degraded.

We will inform you as soon as we have an update.

Posted 28 Sep at 11:37am PDT.